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Reports

* Reports are formatted output of the results of
gueries.

e Access has two ways to create reports:

— Custom Reports
— Report Wizard

* In both cases, you need a query that contains
the information you want to put into the
report.



The Orders Database

The database contains data for orders placed by
customers.

For each order we collect what was ordered, how

much of that item was ordered, and at what
orice.

~or each order we track who placed that order.

~or each customer (called a contact) we store
where they live.

For each product that we sell we track the
product’s description and price.




Customer:

The Orderlnvoice Report

Matthew's Computer Store

Eleanor Milgrom
7245 NW 8 Street
Margate, FL 33063

Order Number: Q0008

Quantity Product Name

1

=ow = R

CD-ROM: 32X

4 GB SCSI Hard Drive
20" Multisync Monitor
Pentium 117450 MHz
Pentium 11/300 MHz

Wednesday, June 22, 2011

CS1100

Sudbury, MA 01776

Microsoft Access

Order Date:

UnitPrice

5249.00
$1,245.00
$1,599.00
£2,299.00
51,599.00

Order Tota

4/22/1999

Extended Price
5249.00
$2,490.00
$6,396.00
$6,897.00
51,599.00

$17,631.00
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Parameterized Query

* Allows user to input a specific value for a
query.

— E.g. ask user what name, zip code, product, etc.
they would like information about.

* |n the criteria field, set an attribute that does
not exist in any joined tables.



Parameterized Query

* |n the criteria field, set an attribute that does

not exist in any joined tables.

Contacts
&

k

% ContactD
FirstMame
LastMame
Address
ZipCode
PhoneMumber |*

Enter Parameter Value @lﬁ

LastMameValue

Lee|

[ oK : ] [ Cancel

Field: | ContactlD LastMame ZipCode |1|
Table: | Cantacts Contacts Contacts
Sort:
Show: E
Criteria: [LastMameValue]
or:
CS1100 Microsoft Access

ContactlD - LastMame - | ZipCode -

il Lee 45501
(Mew)
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The Query for the Report

 What fields do we need for this report?

: Ord
Line termns d EZS
*
' % OrderD
? LineltemD reer
OrdID ContactID
PradID OrderDate Contacts ZipCodes
Quantity * - a.
UnitPrice ¥ ContadD ¥ ZipCode
Product Firsthame City
roducts LastName State
*
) Address
# ProduciD ZipCode
Froducthlame PhoneMumber
Current Unit Price
UnitsInStock
Width
Height
Depth
Weight
1
Field: | OrderlD [+] OrderDate FirstMame LastMame Address City State ZipCode ProductMame
Table: | Orders Orders Contacts Contacts Contacts ZipCodes ZipCodes Contacts Products
Sort:
Showr
Criteria: | [OrderlDValue]
orn
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Report Wizard

Home Create External Data Database Tools Design
fie = =g | Form Wizard 5 | = ﬁ Report Wizard
HE M RKRE B3 N
— — === o [ Navigation = == 12 Labels
Table Table SharePoint | Query Query Form Form  Blank Report Report EBlank
Design  Lists = Wizard Design Design  Form ‘EIMWE Farms ~ Design Report
Tables Queries Forms Reports
i
Report Wizard . - -

Which fields do you want on your report?

- p - You can choose from more than one table or query.

Tables/Queries

R Query: InvoiceQuery E|

Available Fields: Selected Fields:

1 | OrderID

OrderDate

[ oy | |Firstiame
_JLastMame

Add
::i*qan::SS
State

[ »

i ZipCode - il
0 < Back [ Next > ] [ Finish |
CS1100 Microsoft Access 8 Northeastern University
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CS1100

Grouping Data in Reports

Report Wizard

How do you want to view your
data?

by Products
by Line Items
by ZipCodes
by Contacts

by Orders

Show me more information

FI

OrderID, OrderDate, FirstMame,
LastMame, Address, City, State, ZipCode

ProductiMame, Quantity, UnitPrice,
ExtPrice

Cancel

|| < Back || Mext = ||

Finish

Microsoft Access
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Grouping Levels

Report Wizard
Dﬂl you want to add any grouping
levels? State
City
FirstMame

ZipCode

LastMame
: Address

Grouping Cptions ... | | Cancel | ‘ < Back " Mext = | | Einish

CS1100 Microsoft Access 10 Northeastern University
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Sorting and Layout

Report Wizard Report Wizard

How would you like to lay out your report?

What sort arder do you want for detail records?
You can sort records by up to four fields, in either Crientation
ascending or descending order.
d ? @ Portrait
(0) Landscape

g B
™) Qutline
: 5 A

3
4
Adjust the field width so all fields fit on
a page.
Cancel I [ < Back ][ Mext = I [ Finish Cancel I [ < Back ][ Mext = I [ Finish
11 Northeastern University
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Report Design

T T e L S S O T S S U S S S S U SO - S S S U S S SO : S S S N S SR SRR

# Report Header

:::::|Drd|| Orde||FirstMame ||LastName ||Address

="Page " & [Page] & " of " & [Pages]
# Report Footer

CS1100 Microsoft Access 12 Northeastern University
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Report Design

="Page " & [Page] & "of "& :Jages]|

Headers and footers are for data/labels that
describe the section (e.g. Order ID for the
header, and Order Total for the footer)



Report Design

T T e L S S O T S S U S S S S U SO - S S S U S S SO : S S S N S SR SRR

# Report Header

="Page " & [Page] & "of "& :Jages]|

# Weport Footer

The Detail section is repeated for each item
in the query (e.g. Line Item information)

- Northeastern University
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Text vs. Controls

 Note that there are two icons for adding
“text” — they are NOT the same:

abl Aa

ab] The Text Box allows you to add a field from
the query; must be bound to a field

Aa The Label allows you to add free-form text



Rearranging the Report

e Move items to where you want them.
 Each item is a field plus a label.
e Fields can contain “expressions”:

...........................................................

e Create a new text box for each expression, do
not reuse an existing one (will cause errors)

i Northeastern University
CSllOO MlcrOSOft Access 16 College of Computer and Information Science



Adding a Footer

* In Design View, under the Design Tab, click
Group & Sort

Home Create External Data Database Tools | Design | Arrange

ﬁ @Themes A [[Ei Group & Sc:rl:] K j L ,_I;? Logo
B Colors - | E Totals 5 13 Title
View o _ Controls Insert Page _ A
- A|Fonts - 123 Hide Details - Image * | Numbers E;. Date and Time
Views Themes Grouping & Totals

Contrals Header / Footer

Group & Sort

i Northeastern University
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Adding a Footer

e Select More to display OrderlD settings:

Group, Sort, and Total

EI aroup on OrderID ™ from smallest to largest ™ o | aore h\

£ Add 3 group zl Add a sort More

e Select the dropdown to add a footer:

Group, Sort, and Total

. Group on OrderID ™ from smallest bo largest ™ o by entire walue ™ 5 with no kokals ™ 5 with title click to add ,

with a header section ™ + without a Fooker section ™, do not keep group together on one page ™ Less A

- [= Add 3 group Al '.-‘-.'?th a Footer SEEtiDn.
|: without a Footer sectu:N Ad d a fo Ote r

CS1100 Microsoft Access 18 Northe 1L,'ni\‘m':<i y
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Aggregating Over Details

* Now that you have added a footer to the
group (OrderID) you can aggregate over the
details of the group (Line Items).

e Use aggregate functions (things available in
the Total field of query design view) in Text
Box expressions.




Aggregating Over Details

* Now that you have added a footer to the
group (OrderID) you can aggregate over the
details of the group (Line Items).

e Use aggregate functions (things available in
the Total field of query design view) in Text
Box expressions.

Ink Jet Printer 1 $249.95 $249.95
Laser Printer (network) 1 41 395.00 $1,395.00
Pentium 11/350 MHz 2 41 999.00 $3,998.00

5642.95



Fixing Label Borders

* In the Layout View,
click the label with

the border

* Then go to Format,
Shape Outline, and
check Transparent

CS1100

(A
F b3 shape Fill =
o=
£ r':_f? Shape Cutline -
Congti=—==t
Farm .

Automatic

Control theme Colors

1ter Store
)1776

Order Date:

Microsoft Access

|

|

EEN
EEEEEEEEER
HE EEEER
Recent Col
||

4/22/1 Transp t
} More Colors...
Northeast L
21 ge of Col



Changing Colors

e In Design View, click on the field or area, then
go to the Format tab, and click the paint
bucket to choose a color.



Changing Colors

19~ = [ | 805 - Access Reporting @ Dat:
. Home Create External Data Databasze Toals Design Arrange Format I FPage Setup
roupHeaderd - h | o - 2 I I
e a coior- -
dect Al B JF U | Background Alternate
- Image~  Row Calar~
Selection Fo Sutomatic imber Background Control Farmatting
E Ordernvoice Theme Colors
H EEENEEN
1 1 | © 4 1 © R I B ot 7o I

Standard Colors

F Page Header

10rderDate

ol |
B :|I=[FirstMame]+" "+[LastMal EEEEE
- || |address Ty
i =[City]+", "+[State]+" "+[Z I W EEEERE
1 — Recent Colors
EE B
3 18 More Colaors,.,
CS1100

Microsoft Access

L Extenfied Price)
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Formatting Values

e In Design View, click on the field or area, then
go to the Format tab. There is the same
formatting pane that there was in Excel.

AT

File Home

¥ Text27 -

[ Select All

Selection

Create

Calibri (Detail)

External Data Database Tools

B I U

Report Design Tools m - Access Reporting : Database (Access M’ - Zﬂlsmlclﬁ.

rrange | Format | Page Setup
}Jj 4 Shape Fill -
=7
£ # shape Qutline =

Currency

$

CTR <_--0 -0_0 Bagkground Conditional
mage Formatting

Mumber Background Control Formatting

All Access Objects

-

«

Tables
Contacts

Line Items
Crders

Products

ERERERENE

ZipCodes

»

Queries
EF ContaciZip
‘jj InvoiceQuery

»

Reports
il orders

CS1100

o

__I%I|Orde||FirstName ||Last|\|ame ||Address
Detail

roductMame

# OrderlD Footer

Sumt[ExtPrice]].

# Page Footer

=MNow()
# Report Footer

="Page " & [Page] & "of " & [Pages]|
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Formatting Values

e In Design View, click on the field or area, then
go to the Format tab. There is the same
formatting pane that there was in Excel.

Ink Jet Printer 1 $249.95 $249.95
Laser Printer (network) 1 41 395.00 $1,395.00
Pentium 11/350 MHz 2 £1,999,00 $3,998.00



The Orderlnvoice Report

# Report Header
55550606060000000060000[c5060600000000650000050][06060000000060000055060 I ................................................................................................................. e

Grrphiasione
A OT A6

[uanting: Praucs Mameiis | s Hils | oniewes] [ bueatied peed LD

# Detail
§|C1uantiw|§§|Pmduc1Name |
# COrderlD Footer

3| [=sum[ExtPrid]

# Page Footer

=MNow()

[ NS Y R

="Page " & [Page] & " of " & [Pages]|
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Create a Pivot Table from an Access Table

From the Data Menu, choose “From Access”

|{& From Access

Home

Insert Formulas

Data

@ I_@ Connections 4
2
g From Web e Properties
isting Refrash ) 3
Connections All~ &= Cdit Links
et External Data Connections
Al - F |
i N
Select Table ? £
. . Mame Description  Modified Created Type
Find your Access file i OrderInfo 4/12/2012 8:08:51PM  4/12/2012 8:08:51PM  VIEW
%] Contacts 102772010 9:45:31 AM 10/20/20058 9:57:08 AM  TABLE
and choose the table or Bc 27 20
Line Items 10242010 3:11:494 PM 10/20/2008 10:19:37 AM  TAEBLE
query to use Iin your Orders 10/20/2008 10:39:43 AM  5(6/1994 12:58:54PM  TABLE
) Products 10/2/2010 3:12:24PM  6/6/1994 12:58:58 PM  TABLE
P ivot table. ZipCodes 10/27/2010 9:45:46 AM  10/20/2008 9:55:41 AM  TABLE
[ K J [ Cancel
P
L &
CS1100 Pivot tables and charts 27 Northeastern University
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Summary

Queries can have parameters.

Reports allow information technology
professionals to provide data in a more
readable format to users.

The Access Wizard creates reports based on
gueries.

The Report Designer allows reports to be
designed using simple “drag-and-drop”.



TRY FOR YOURSELF...

Northeastern University
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